Menu
Reply
  • 6
  • 0
  • 2
yaqubk
Tuning in
8,206 Views
Message 1 of 8
Flag for a moderator

Consistent High ping and Lag spikes

Hey,

 

I've been on Virgin media for a few years now and currently have the 50mb Broadband package, I've also been playing League of Legends for around 2 years now.

 

I've always had a consistent 27-35 ping in game which is great, no lag etc. Until recently around 2 - 3 weeks ago EVERY single game my average ping has been 50+ and sometimes spikes to 150-700 at max. The game now is unplayable, even when my ping is low for a few seconds I have a lot of packet loss, the same goes for my brother who also plays on the same network. 

 

Something else I've noticed is when I play with my friends, who are also on Virgin media they lag and spike near enough the same time as us.

 

I did some research to see if anyone else was experiencing the same issues and there were a lot of topics, although I came across this one:

 

https://www.reddit.com/r/ffxiv/comments/2vg7ep/uk_virgin_media_lag_issues/

 

The top comment in the post says that VM has recently changed routing partners to GTT and apparently they have been having routing issues with one of their servers, this being posted 4 months ago I would've expected it to be fixed by now.

 

I decided to do a traceroute to the EUW servers and this is the output:

 

server1:


Tracing route to 185.40.65.1 over a maximum of 30 hops

1 14 ms 37 ms 55 ms cpc4-blbn9-2-0-gw.10-1.cable.virginm.net [82.27.140.1]
2 19 ms 23 ms 19 ms manc-core-2b-xe-1002-0.network.virginmedia.net [82.8.209.237]
3 * * * Request timed out.
4 * * * Request timed out.
5 * * * Request timed out.
6 13 ms 19 ms 237 ms manc-bb-1c-ae1-0.network.virginmedia.net [62.254.42.242]
7 18 ms 175 ms 24 ms ae0.man11.ip4.gtt.net [77.67.65.141]
8 118 ms 39 ms 32 ms et-5-1-0.ams60.ip4.gtt.net [141.136.105.185]
9 30 ms 29 ms 30 ms riot-games-gw.ip4.gtt.net [77.67.67.18]
10 * * * Request timed out.
11 22 ms 219 ms 61 ms 185.40.65.1

Trace complete.

 

Server2:


Tracing route to 162.249.72.1 over a maximum of 30 hops

1 7 ms 14 ms 16 ms cpc4-blbn9-2-0-gw.10-1.cable.virginm.net [82.27.140.1]
2 18 ms 16 ms 18 ms manc-core-2b-xe-1002-0.network.virginmedia.net [82.8.209.237]
3 * * * Request timed out.
4 * * * Request timed out.
5 * * * Request timed out.
6 * * * Request timed out.
7 15 ms 21 ms 18 ms brhm-bb-1b-ae0-0.network.virginmedia.net [62.254.42.106]
8 21 ms 163 ms 24 ms ae1.lon25.ip4.gtt.net [77.67.65.161]
9 34 ms 36 ms 35 ms xe-1-2-1.fra23.ip4.gtt.net [89.149.184.78]
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.

Trace complete.

 

I've highlighted in red where I think the problem is, the ping is too high when routing through the GTT server, so thats crossing out the LoL servers being the issue. My friends on SKY and such don't have this problem. 

 

 

I then ran this netalyzr to check if there's anything wrong with the network:

netalyzr.icsi.berkeley.edu/

 

 

I don't know if this would be of any use to you.

 

I have also done a ping monitor using thinkbroadband which is here:

 

 

My Broadband Ping - LoL

 

 

You can see that the minimum latency is very high, honestly this just sucks, I can't play with my friends anymore.

If the problem is with GTT PLEASE get in contact with them to resolve the routing issue. Also, I have the virgin SuperHub, not the new one that has the 5ghz band as well as the 2.4ghz, the one before. I've port forwarded for the servers and everything else I need to, restarted the router, flushed my DNS, changed my adapter settings to have google dns servers and it hasn't fixed anything. Please help.

 

I forgot to add that I'm on a wired connection as is my brother, also here are the network logs and such of the router if they may be of any help:

 

I also did a speedtest and had a 2.8mb upload and a 47mb download speed.


Helpful Answers
  • 9.74K
  • 314
  • 839
legacy1
Hero
15,973 Views
Message 2 of 8
Flag for a moderator
Helpful Answer

Re: Consistent High ping and Lag spikes

Reboot your super hub router mode.

All Replies
  • 9.74K
  • 314
  • 839
legacy1
Hero
15,974 Views
Message 2 of 8
Flag for a moderator
Helpful Answer

Re: Consistent High ping and Lag spikes

Reboot your super hub router mode.
  • 6
  • 0
  • 2
yaqubk
Tuning in
8,189 Views
Message 3 of 8
Flag for a moderator

Re: Consistent High ping and Lag spikes

I already said in the OP that I have tried doing that.
0 Kudos
  • 9.74K
  • 314
  • 839
legacy1
Hero
8,183 Views
Message 4 of 8
Flag for a moderator

Re: Consistent High ping and Lag spikes


yaqubk wrote:
I already said in the OP that I have tried doing that.

When? A week a go? Maybe a month a go? I know because if you had done a reboot some days a go even with the SH1 logs show 1 month offset your logs would show 7/6/2015 for the most recent logs and if you did reboot your logs would be cleared which they are not.

 

Your in router mode reboot.

0 Kudos
  • 6
  • 0
  • 2
yaqubk
Tuning in
8,176 Views
Message 5 of 8
Flag for a moderator

Re: Consistent High ping and Lag spikes

I did when the problems started occurring, I just rebooted.

Can I ask how rebooting would maybe fix the issue? Like what's going on with the superhub to cause this?

Thanks
0 Kudos
  • 9.74K
  • 314
  • 839
legacy1
Hero
8,171 Views
Message 6 of 8
Flag for a moderator

Re: Consistent High ping and Lag spikes


yaqubk wrote:

Can I ask how rebooting would maybe fix the issue?

It just did!


yaqubk wrote:

Like what's going on with the superhub to cause this?


Don't really know, NETGEAR would if they looked given they did the firmware or so I would think.

 

If you what it stable use modem mode.

0 Kudos
  • 6
  • 0
  • 2
yaqubk
Tuning in
8,158 Views
Message 7 of 8
Flag for a moderator

Re: Consistent High ping and Lag spikes

Thanks. It seems to have been fixed, the traceroutes seem to be saying the latency is much lower, haven't had a game yet, will post back when I have. I used to use modem mode until both routers died in the span of 3 years, will invest in a new one.
0 Kudos
  • 6
  • 0
  • 2
yaqubk
Tuning in
8,136 Views
Message 8 of 8
Flag for a moderator

Re: Consistent High ping and Lag spikes

Just had a game, consistent 26-27 ping. It's fixed!

 

To anyone who is reading this topic, I didn't reboot by switching the router on and off by the switch, I logged in and went into advanced settings and rebooted from there. You can see from the ping graph the difference it's made after rebooting.