Menu
Reply
  • 324
  • 11
  • 49
SDC
Fibre optic
277 Views
Message 1 of 23
Flag for a moderator

Webmail setting being ignored

In VM webmail I clearly have a valid Auto forwarding rule enabled, to "forward ALL incoming email messages" to my valid Gmail address. I have no other rules set, and no Holiday Notice set:

 

autoforwardrule.jpg

 

 And I clearly have "ALL spam filtering" turned off:

 

 

 spamsettings.jpg

 

 

 

 

 So why is VM webmail still filtering spam into my spam folder and not forwarding it to Gmail?

 

 

stillspam.jpg

 

 

Are they footering about with it again?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Less-than-Super User, going from bad to worse since signing up to Diamond Cable and JANET all those years ago.
Use Kudos to show your appreciation, send Hobnobs to really show your appreciation :-)
Mark answer as "helpful" only when the problem is solved.
I do not work for VM... or for anyone else except SWMBO.
Please note that the tone in which you read this post may not be the same as my tone when I created it.
0 Kudos
Reply
  • 244
  • 33
  • 119
coenoby
Superfast
241 Views
Message 2 of 23
Flag for a moderator

Re: Webmail setting being ignored

Hi SDC

I think we already know that the VM auto forward only works on messages that go to the inbox.

You have turned off the spam filter so the question is why are you seeing messages being sent to your spam folder?

The answer is explained in this threadEmail/Mailchimp-message-going-to-spam

The issue there was that the OP had set the email address of his golf club as a contact but VM was still sending their messages to the spam folder.

VM have implemented more thorough email authentication procedures (see message 7 of this thread where Ravenstar68 explains how it all works) Ravenstar-s-Email-FAQ

I'll try to give a simple explanation but you should look at Ravenstar68's post for the full technical details.The bottom line is that VM carry out  2 checks when an email arrives.

1) Firstly, a check on the authenticity of the message, i.e. does it really come from the sender that it appears to come from? Essentially, that means checking the domain name of the email address and the server the email came from. If the server is not authorised to send emails for that domain then the email will fail the authenticity check.

2) Only if the email passes that check will the spam filter decide whether it looks like spam. Emails that fail the authenticity check do not go through the spam filter. They are either sent to the spam folder or rejected.

It is likely that the 'spam' that you are seeing in your spam folder are emails that have failed the authenticity check and been put into your spam folder as being potential spoofed emails.

Those emails could be 'genuine' spoofed emails (in the sense that someone is trying to deceive you) but probably many are like the example in the Mailchimp thread where the golf club are using Mailchimp to send out newsletters. The golf club has a Talktalk email account and Talktalk have set up their SPF record to specify that they expect @talktalk.net emails  to be sent from talktalk's own servers. Because the golf club are using Mailchimp the emails are not being sent through a Talktalk  server and so they fail the authentication check. VM therefore puts them into the receiver's spam folder but with no explanation why.

I have made the point in the Mailchimp thread that VM needs to make it clear to everyone that their spam folders may contain potentially spoofed emails as well as spam. Until that happens there are going to be a lot of confused webmail users.Smiley Sad

coenoby

*******************************
If someone posts a helpful message you can say thanks by clicking on the thumbs up in their post.
If someone posts a message that solves your problem it helps everyone if you mark their post as an Accepted Solution.
  • 324
  • 11
  • 49
SDC
Fibre optic
226 Views
Message 3 of 23
Flag for a moderator

Re: Webmail setting being ignored

Thanks for the explanation, coenoby.

 


coenoby wrote:

I think we already know that the VM auto forward only works on messages that go to the inbox.


Well, I didn't know that it was supposed to work like that. When the option is clearly presented as "Forward all incoming email messages", I truly expected it to forward ALL incoming email messages, not SOME incoming email messages. Maybe it's just me, but maybe someone should revamp the displayed message so that it's not misleading.

 

coenoby wrote:

You have turned off the spam filter so the question is why are you seeing messages being sent to your spam folder?


If I change the spam filter to "Flag a message as spam but deliver to inbox" as per your recommendation in my "Auto Forwarding and webmail Spam Settings" thread, would they then become forwardable (is that a real word?)? Your reasoning was "That way you will get all emails into Gmail and any emails identified as spam by VM will be flagged as such. You can then manage everything in Gmail".

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Less-than-Super User, going from bad to worse since signing up to Diamond Cable and JANET all those years ago.
Use Kudos to show your appreciation, send Hobnobs to really show your appreciation :-)
Mark answer as "helpful" only when the problem is solved.
I do not work for VM... or for anyone else except SWMBO.
Please note that the tone in which you read this post may not be the same as my tone when I created it.
0 Kudos
Reply
  • 324
  • 11
  • 49
SDC
Fibre optic
220 Views
Message 4 of 23
Flag for a moderator

Re: Webmail setting being ignored


coenoby wrote:

... Until that happens there are going to be a lot of confused webmail users.Smiley Sad


I'm confused by that...

Do you mean "confused users of webmail", or "users of confused webmail"?

Or both?

Smiley LOL

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Less-than-Super User, going from bad to worse since signing up to Diamond Cable and JANET all those years ago.
Use Kudos to show your appreciation, send Hobnobs to really show your appreciation :-)
Mark answer as "helpful" only when the problem is solved.
I do not work for VM... or for anyone else except SWMBO.
Please note that the tone in which you read this post may not be the same as my tone when I created it.
0 Kudos
Reply
  • 324
  • 11
  • 49
SDC
Fibre optic
215 Views
Message 5 of 23
Flag for a moderator

Re: Webmail setting being ignored

And today, just for good measure, two more incoming messages. Obvious spams. Webmail didn't put them in the spam folder, it put them in the inbox. And Webmail did not forward them to Gmail.

This whole forwarding malarkey is a farce.

 

spamininbox.jpg

 

 

 

 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Less-than-Super User, going from bad to worse since signing up to Diamond Cable and JANET all those years ago.
Use Kudos to show your appreciation, send Hobnobs to really show your appreciation :-)
Mark answer as "helpful" only when the problem is solved.
I do not work for VM... or for anyone else except SWMBO.
Please note that the tone in which you read this post may not be the same as my tone when I created it.
0 Kudos
Reply
  • 1.4K
  • 149
  • 444
用心棒
Knows their stuff
198 Views
Message 6 of 23
Flag for a moderator

Re: Webmail setting being ignored


coenoby wrote:

It is likely that the 'spam' that you are seeing in your spam folder are emails that have failed the authenticity check and been put into your spam folder as being potential spoofed emails.

Those emails could be 'genuine' spoofed emails (in the sense that someone is trying to deceive you) but probably many are like the example in the Mailchimp thread where the golf club are using Mailchimp to send out newsletters. The golf club has a Talktalk email account and Talktalk have set up their SPF record to specify that they expect @talktalk.net emails  to be sent from talktalk's own servers. Because the golf club are using Mailchimp the emails are not being sent through a Talktalk  server and so they fail the authentication check. VM therefore puts them into the receiver's spam folder but with no explanation why.

I have made the point in the Mailchimp thread that VM needs to make it clear to everyone that their spam folders may contain potentially spoofed emails as well as spam. Until that happens there are going to be a lot of confused webmail users.Smiley Sad


IMHO,  this is not a documentation issue but a bug that Virgin Media need to address and the destination for all suspicious emails should be as defined by the user under SPAM settings.

  • 244
  • 33
  • 119
coenoby
Superfast
194 Views
Message 7 of 23
Flag for a moderator

Re: Webmail setting being ignored


用心棒 wrote:

IMHO,  this is not a documentation issue but a bug that Virgin Media need to address and the destination for all suspicious emails should be as defined by the user under SPAM settings.

 

I certainly would not argue against that. Actually I was just being pragmatic.

Currently the documentation does not reflect the way the system works. If VM can change the functionality in webmail in a timely manner, then that would be ideal. In reality it's easier for them to change the documentation to reflect the current system so that there is more chance of that being done.

The important thing to me is that at present it's just very confusing so something needs to be done.

coenoby

 

 

 

 

 

*******************************
If someone posts a helpful message you can say thanks by clicking on the thumbs up in their post.
If someone posts a message that solves your problem it helps everyone if you mark their post as an Accepted Solution.
  • 324
  • 11
  • 49
SDC
Fibre optic
187 Views
Message 8 of 23
Flag for a moderator

Re: Webmail setting being ignored

Only tenuously related I know, but I've just come home to find one of my three monthly Virgin Mobile bill notifications had been sent to the old ntlworld address instead of to the new Gmail address (they've only had a month to sort that), and Gmail had decided that my monthly Virgin Media BB package bill is spam. Feel free to LOL.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Less-than-Super User, going from bad to worse since signing up to Diamond Cable and JANET all those years ago.
Use Kudos to show your appreciation, send Hobnobs to really show your appreciation :-)
Mark answer as "helpful" only when the problem is solved.
I do not work for VM... or for anyone else except SWMBO.
Please note that the tone in which you read this post may not be the same as my tone when I created it.
0 Kudos
Reply
  • 13.5K
  • 711
  • 4.65K
Superuser
Superuser
167 Views
Message 9 of 23
Flag for a moderator

Re: Webmail setting being ignored

I'm going to start by commenting on @用心棒 comment.

First of all the DMARC policy says that receiving domains SHOULD adhere to the sending domains policy.  It does go on to say that the mail server MAY choose to override that policy, but should put the reason for such an override in the trace headers fields.

Being as

1. DMARC itself is relatively new, (DKIM and SPF have been around a little longer, but DMARC was added to provide sending domain administrators with a means of controlling what happens to mail that doesn't originate from their servers).
2. Virgin doesn't yet put required information such as the results of SPF and DKIM checks in their trace header fields.

I don't expect any changes to this to be implemented any time soon.  Remember if Virgin forward suspect mail then their own server's reputation could suffer.

HOWEVER, I'd be wary about putting this down to DMARC without viewing the headers of the mails in question.  From the screenshots we can't view the actual From: address or even the envelope sender.  I don't like jumping to conclusions.  When I deal with a mail problem, I like to analyse it properly, then come up with a solution.

Mail forwarding itself SHOULD be working I've turned this on on one of my virginmedia.com accounts and tried sending me an email from outside the Virgin network, the mail was received in my virginmedia.com inbox AND auto-forwarded to the desired address.

Intriguingly I also tried forwarding a spam mail and then composing a new mail in webmail and then sending it.  Both mails are showing in my Sent Objects folder, but  at the time of writing neither of them have appeared at their destination.

@Nicola_C  Could you take a look at this when you get time.  I recall seeing another thread that Emma was in where a user was saying mail from one Virgin address to another was delayed, and I'm wondering whether all these issues are related.

Tim

________________________________________


Only use Helpful answer if your problems been solved.

0 Kudos
Reply
  • 9.02K
  • 295
  • 963
Forum Team
Forum Team
156 Views
Message 10 of 23
Flag for a moderator

Re: Webmail setting being ignored

 

 

@ravenstar68 Thanks Tim where could they be, is it worth waiting a bit longer for them for arrive or perhaps NDR? If they do we will have more to go on then.

 

 

Nicola

Virgin Media Forum Team
0 Kudos
Reply