Menu
Reply
  • 27
  • 1
  • 5
leenash
On our wavelength
496 Views
Message 1 of 15
Flag for a moderator

Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

Hi Guys

Outgoing emails via smtp.ntlworld.com have stoppped yesterday afternoon, 30/11/16.

Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error.

Server SMTP error log shows: 451.4.4.0 Primary responded with "525 Auth Denied (VM320) and "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

 

Setup is:

MS outlook to SBS2011.

SBS2011 SMTP via connector to smtp.ntlworld.com using xxx@virginmedia email/password as authorisation.

Webmail log in is working via VM Portal.

its looking like smtp.ntlworld.com is not allowing outgoing emails with the supplied credentials?

Called VM this morning and was told account standing was all good and no restrictions were in place.

But they said....... "there was some back-end work being done with ntlworld.com emails/routing?"

 

so, any ideas or similar problems?

 

emails are still backed up unable to be sent. (no more than 10 emails a day)

 

0 Kudos
Reply

Helpful Answers
  • 13.65K
  • 720
  • 4.73K
Superuser
Superuser
682 Views
Message 12 of 15
Flag for a moderator
Helpful Answer

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

I already have Stunnel set up on my machine.

To set it up do the following.

1. Download and install stunnel-5.38-installer.exe from the stunnel site.
2. When you install you'll be asked to set the parameters of a self signed certificate that Stunnel requires in case you want to configure inbound connections over TLS.
3 In the stunnel folder select Edit stunnel.conf which will open up notepad and load the file.
4. Scroll down to the services section.  You'l see some example services for connecting to Gmail.  So we just need to modify these entries.

; **************************************************************************
; * Service definitions (at least one service has to be defined)           *
; **************************************************************************

[virginmedia.com smtp]
client = yes
accept = 127.0.0.1:25
connect = smtp.virginmedia.com:465
verifyChain = yes
CAfile = ca-certs.pem
checkHost = smtp.virginmedia.com
OCSPaia = yes

5. Save the changes if the Stunnel is not yet running start it up.  If it is running right click it's icon in the notification area and select reload configuration.
6. Test the Tunnel by opening a command window and using telnet 127.0.0.1 25 you should see the following.

220 know-smtprelay-10-imp bizsmtp ESMTP server ready

Once you've got this working you can configure your connector to point to 127.0.0.1 port 25 and stunnel will do the rest.

Ravenstar68

PS - being that localhost is actually the entire 127.x.x.x netblock we can configure stunnel to listen on different IP addresses on port 25 and connect to the relevant server.  Here's a more advanced configuration file allowing tunnels to all four Virgin smtp servers.

[blueyonder smtp]
client = yes
accept = 127.0.0.1:25
connect = smtp.blueyonder.co.uk:465
verifyChain = yes
CAfile = ca-certs.pem
checkHost = smtp.blueyonder.co.uk
OCSPaia = yes

[virginmedia smtp]
client = yes
accept = 127.0.0.2:25
connect = smtp.virginmedia.com:465
verifyChain = yes
CAfile = ca-certs.pem
checkHost = smtp.virginmedia.com
OCSPaia = yes

[ntlworld smtp]
client = yes
accept = 127.0.0.3:25
connect = smtp.ntlworld.com:465
verifyChain = yes
CAfile = ca-certs.pem
checkHost = smtp.ntlworld.com
OCSPaia = yes

[virgin smtp]
client = yes
accept = 127.0.0.4:25
connect = smtpvirgin.net:465
verifyChain = yes
CAfile = ca-certs.pem
checkHost = smtp.virgin.net
OCSPaia = yes

In this setup 

127.0.0.1:25 -> smtp.blueyonder.co.uk:465
127.0.0.2:25 -> smtp.virginmedia.com:465
127.0.0.3:25 -> smtp.ntlworld.com:465
127.0.0.4:25 -> smtp.virgin.net:465

There is no reason to be connecting to any of the Virgin Media servers using port 25 and several reasons not to.

Raven

________________________________________


Only use Helpful answer if your problems been solved.


All Replies
  • 1.46K
  • 115
  • 359
Superuser
Superuser
492 Views
Message 2 of 15
Flag for a moderator

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

Do you have an ntlworld or virginmedia.com email address?
Have you tried using the virginmedia.com server settings?


Virginia/Doctor9fan. If I have helped please give me Kudos.
0 Kudos
Reply
  • 7.37K
  • 832
  • 3.11K
Superuser
Superuser
491 Views
Message 3 of 15
Flag for a moderator

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

You seem to be hitting the hourly sending limits which are very restrictive and not disclosed by VM though the daily ones are. The issue should clear in 24 hours. But I wonder are you sending via VM's SMTP server over the VM network or something else?

-----------------------

Superuser 2017/18
Use Kudos to say thanks
Mark answer as "helpful" only when the problem is solved
Please don't send me private messages unless I ask you to.
I do not work for VM. The advice I give is based on my best understanding of VM policy and practice. You rely on it at your own risk.
0 Kudos
Reply
  • 27
  • 1
  • 5
leenash
On our wavelength
484 Views
Message 4 of 15
Flag for a moderator

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

Hi, we have a virginmedia.com email address.

being used to access the smtp.ntlworld.com server.

we haven't managed to get the virginmedia.com server settings working on a send connector in SBS2011 yet.

0 Kudos
Reply
  • 27
  • 1
  • 5
leenash
On our wavelength
481 Views
Message 5 of 15
Flag for a moderator

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

HIya,

sending email via smtp.ntlworld.com, using xxx@virginmedia.com used for authorisation

not exceeding the send limits as its only 8 emails since yesterday.

 

all was working fine with no changes at our end.....until yesterday.

 

last time this happened a month or so ago it was due to VM deleteing the xxx@virginmedia.com used for authorisation due to lack of use.

this time its different as the new webmail is still working fine and the smtp error is different.

Also its already been over 24hours, 

0 Kudos
Reply
  • 7.37K
  • 832
  • 3.11K
Superuser
Superuser
480 Views
Message 6 of 15
Flag for a moderator

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

SBS2011 - MS's Small Buisness Server. Out of my field of knowledge I'm afraid. Someone else will be along to help soon - I hope.

-----------------------

Superuser 2017/18
Use Kudos to say thanks
Mark answer as "helpful" only when the problem is solved
Please don't send me private messages unless I ask you to.
I do not work for VM. The advice I give is based on my best understanding of VM policy and practice. You rely on it at your own risk.
0 Kudos
Reply
  • 13.65K
  • 720
  • 4.73K
Superuser
Superuser
455 Views
Message 7 of 15
Flag for a moderator

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

You've got two different issues going on here.

453 VM501 is too many recipients in the last hour.  Note that this is not just about individual emails, it's about the total number of recipients sent.

While I don't know the actual recipient limit - let me give as an example a recipient limit of 10 recipients per hour.

You send 3 emails in under an hour

First to 8 recipients
Second to 2 recipients
Third to 1 recipient.

The second email puts you at the hourly recipient limit so the third mail is rejected with too many recipients.

NOTE - The above figures are used for illustrative purposes and should not be taken as Virgin's actual hourly limits.

The VM320 Error is a different beast.  That says that there have been too many Authentication attempts in the last hour, and the account has been temporarily locked out.

You also mention that you cannot Authenticate using your ntlworld.com address.  What error are you seeing when you try this?

Finally - as you are using SBS - can I ask are you in fact using your ntlworld.com address as a business address?

If so this is not best practice.  Virgin's email service is provided gratis for residential use only.  As such, in line with the other free email providers, it comes with no guarantees of uptime or SLA's regarding how long it takes to resolve individual issues.  It is also IMHO vastly inferior to many of the other free offerings out there currently.

Ravenstar68

________________________________________


Only use Helpful answer if your problems been solved.

  • 27
  • 1
  • 5
leenash
On our wavelength
448 Views
Message 8 of 15
Flag for a moderator

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

Hi Ravenstar68,

i have now deleted all the outgoing held up mail, and re sent 1 test email to myself at a gmail address.

this 1x email to 1x recipient is currently failing to send with error: 451 4.4.0 - 525 Au De (VM320)

 

im trying to send it out via VM SMTP - smtp.ntlworld.com (port 25) using a xxx@virginmedia.com/password.

the setup has been running for years with no issues and no changes at our end. (untill 2 days ago)

Last time this happened Jen-A worked out the yyy@virginmedia.com email address used for authentication had been switched off, this is not the case now as the webmail for xxx@virginmedia.com is working fine.

 

when i called VM they said there was some spam issues with ntlword.com?

many thanks Lee.

0 Kudos
Reply
  • 13.65K
  • 720
  • 4.73K
Superuser
Superuser
435 Views
Message 9 of 15
Flag for a moderator

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

@leenash

There's no point in ringing first line support about e-mail issues.  If it can't be fixed by deleting and recreating an account, then they don't have a clue.

525 Authentication Denied (VM320) is very specific.  As detailed earlier it is related to the Authentication attempts made in the last hour.  So you need to wait for the timer lockout to expire before attempting to send mail.

You never did say what issues you were getting when authenticating with your ntlworld.com address.

Finally I know why you can't connect to smtp.virginmedia.com

SBS uses Microsoft's mail connector service to relay mail.  While this is ok if you use the IANA approved ports for mail submission (25 or 587).  It does not support sending over port 465.

The reason for this is that while port 465 was used for a short period experimentally.  It was never ratified as a standard port for SMTP over SSL by the IANA.  In fact it's use was deprecated in 1998.

Fortunately there is a solution at hand. - stunnel which is available for both Windows and Linux it is available here. https://www.stunnel.org/index.html

By configuring stunnel on your SBS machine and then setting it up to accept a connection on say 127.0.0.1:25 and connect it to smtp.virginmedia.com:465 you can then set up the SBS outbound connector to use 127.0.0.1:25 and pass your Virgin credentials.

Ravenstar68

________________________________________


Only use Helpful answer if your problems been solved.

  • 27
  • 1
  • 5
leenash
On our wavelength
428 Views
Message 10 of 15
Flag for a moderator

Re: Email failed to send - "smtp.ntlworld.com" 453 Too Many Recipients (VM501) Error

Hi Guys

Ive found a work around for my particular issue.

It seams that the 10x email/hr (or whatever it is) limit is causeing VM to block access (temporarily) to the SMTP server and not autherising the username/pass, the net effect is the emails just mount up over time making the matter worse.

weve added additional fallover SMTP connectors with separate email/passwords to spread the load.

Now when i say "load" im talking about only 5x emails..... but 3x of them had 4xrecipiants. - so assuming we being blocked for over use?

 

We added the additional smtp routes below, the assumption is that if the primary route was blocked/banned temporarily then the additional routes could be used to route the emails (up to there own 10x limit/hr) and so on.

 

The end result now is that all the emails have been sent and delivered (thank god) and follow up test emails are being sent ok.

 

primary: smtp.ntlworld.com - port 25 - aaa@virginmedia.com/pass

fallover 1: smtp.virgin.net - port 25 - bbb@virginmedia.com/pass

fallover 2: smtp.blueyonder.co.uk port 25 - ccc@virginmedia.com/pass

 

This obviously isn't an ideal solution.... But until someone can tell me how you get the smtp.virginmedia.com/465/SSL setting to work on SBS2011 it will have to do.

 

many thanks

0 Kudos
Reply